Error Time Zone pada PHP

ERROR:2 : strtotime(): It is not safe to rely on the system’s timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected ‘Asia/Jakarta’ for ‘WIT/7.0/no DST’ instead in /usr/share/ulteo/webclient/PEAR/HTTP/WebDAV/Tools/_parse_propfind_response.php (l.98)

Saat menjalankan aplikasi Ulteo 3.0 rc 4 ternyata terdapat error yang sangat menggangu, sehingga aplikasi tidak berjalan dengan baik seperti membuat folder maupun menyimpan file pada folder. Error seperti ini juga sering terjadi pada aplikasi php lainnya seperti yang saya lakukan pada saat searching di internet untuk mengatasi problem ini.
Tapi jangan kuatir, ternyata cm tinggal tambahkan date.timezone saja pada /etc/php.ini ato /etc/php5/apache2/php.ini (openSuse)

date.timezone = “Asia/Jakarta”

Setelah itu restart Apache anda
/etc/init.d/httpd restart ato /etc/init.d/apache2 restart (OpenSuSE)

Setelah restart maka tidak akan ada lagi error pada function php anda

Referensi
http://vsingleton.blogspot.com/2010/01/you-are-required-to-use-datetimezone.html

Iklan